7
Vote

Some columns's field to be set "None" value automatically when i had just edited the list item to attach a file.

description

"SharePoint Connected Lookup" is a great tool! I like it very much. Just one week ago,i had found it on "cl.codeplex.com" and used it building my working list.
 
Now,I had got the trouble that some columns's field to be set "None" value automatically when i had just edited the list item to attach a file. So i show you with this screen snap {{Attach File}}.

file attachments

comments

leonidly wrote Jun 16, 2009 at 4:07 PM

Thanks for sharing the issue. Please provide repro steps with sample data in English and I will look into it.

JamesWg wrote Jun 17, 2009 at 7:55 AM

Thanks for your fast reponse! I am so sorry for my poor english and i can't build a demo list with the "Employees.stp" template released in "Connected_Lookup_Quick_Start.zip", So I can't show you with my trouble actually. So sorry!

I had found the same issue in "Discussions for SharePoint Connected Lookup":

{Editing an item, It doesn't remember previous values}

URL: http://cl.codeplex.com/Thread/View.aspx?ThreadId=46909

Thanks very much for your solution!

JamesWg wrote Jun 17, 2009 at 10:43 AM

Dear Leonidly:
Here is "Repro steps with sample data", {{Attach File}}.

Thanks your great solution again, Very much!

wrote Jun 17, 2009 at 10:43 AM

leonidly wrote Jun 22, 2009 at 5:59 PM

James,
I won't be soon, but I will repro your steps and publish results.

davelegg wrote Aug 12, 2009 at 5:27 PM

I have a similar problem. The connected lookups cannot be changed when an item is edited. Attemping to do so causes "Uexpected error" messages.
Workaround: Manually set each child connected lookup field to "(None)" , and when the error pops up, use the browser back button to go back to the form. Once all the child fields are cleared, then the connected lookups work again. This required that none of the lookup fields be "required" either.

leonidly wrote Aug 12, 2009 at 7:47 PM

well, still in queue...

wrote Nov 23, 2009 at 8:07 AM

jdamsbo wrote Nov 23, 2009 at 8:13 AM

Thank you for a great solution, which we've been very happy with.

We're also experiencing this very issue, which we consider severe, as users don't realize, that the value in the dropdown has changed from whatever-value to the first/default value. This causes inconsistency in the list data (we're using it for product information - essential for all sales personel), causing errors in customer relations and in general essentially hurting the user's trust in the application.

We really hope, that you'll be able to solve this. I'm sure you have tons to do, but do you have a realistic go-live date for this important fix?

Thx/Jakob

wrote Nov 23, 2009 at 8:37 AM

wrote Nov 23, 2009 at 8:40 AM

wrote Nov 23, 2009 at 8:44 AM

wrote Nov 24, 2009 at 12:15 AM

leonidly wrote Nov 24, 2009 at 2:40 AM

The support and extensions for the solution are now handled by Stoic. Feel free to contact them directly info@stoictech.com if you need custom build or extensions. This forum will remain what it is designed to be, a peer-to-peer network.

wrote Nov 24, 2009 at 5:12 AM

wrote Nov 27, 2009 at 11:59 AM

wrote Jan 20, 2011 at 9:28 PM

wrote Feb 14, 2013 at 12:51 AM