Import Fails on Connected Lookup

Nov 18, 2009 at 4:43 PM

I'm currently trying to migrate some site collections to a new environment, but any site that uses the connected lookup feature is failing. Here is the error below:

FatalError: Request for the permission of type 'Microsoft.SharePoint.Security.SharePointPermission, Microsoft.SharePoint.Security, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' failed.
   at System.RuntimeTypeHandle._GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, Boolean loadTypeFromPartialName)
   at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)
   at System.RuntimeType.PrivateGetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)
   at System.Type.GetType(String typeName)
   at Microsoft.SharePoint.SPFieldCollection.CreateSPField(Int32 index)
   at Microsoft.SharePoint.SPFieldCollection.EnsureSPField(Int32 index)
   at Microsoft.SharePoint.SPFieldCollection.get_Item(Int32 iIndex)
   at Microsoft.SharePoint.SPFieldCollection.GetFieldById(Guid fieldId, Boolean bThrowException)
   at Microsoft.SharePoint.Deployment.FieldTemplateSerializer.GetField(Guid fieldId, SPWeb web)
   at Microsoft.SharePoint.Deployment.FieldTemplateSerializer.SetObjectData(Object obj, SerializationInfo info, StreamingContext context, ISurrogateSelector selector)
   at Microsoft.SharePoint.Deployment.XmlFormatter.ParseObject(Type objectType, Boolean isChildObject)
   at Microsoft.SharePoint.Deployment.XmlFormatter.DeserializeObject(Type objectType, Boolean isChildObject, DeploymentObject envelope)
   at Microsoft.SharePoint.Deployment.XmlFormatter.Deserialize(Stream serializationStream)
   at Microsoft.SharePoint.Deployment.ObjectSerializer.Deserialize(Stream serializationStream)
   at Microsoft.SharePoint.Deployment.ImportObjectManager.ProcessObject(XmlReader xmlReader)
   at Microsoft.SharePoint.Deployment.SPImport.DeserializeObjects()
   at Microsoft.SharePoint.Deployment.SPImport.Run()

I have reviewed the WSS_Custom_Minimal.config security file, and this permission is granted. I'm not sure if this may have something to do with dependancies on list that have not been created yet through the import process. Any assistance is greatly appreciated!

Thanks,

Thomas

 

Coordinator
Nov 18, 2009 at 5:16 PM

Thomas,

Does it fail if you set Trust level to FULL?

Leonid

Nov 18, 2009 at 5:22 PM

I tried that. Unfortunately it did fail. The only thing I haven't tried is modifying the WSP to deploy directly to the GAC and remove the CAS policy from the Manifest.xml file. Do you think this might work?

Coordinator
Nov 18, 2009 at 6:06 PM

I would try dragging dll into GAC and deleting it from BIN

Nov 18, 2009 at 6:09 PM

I tried that yesterday, but based on the CAS Policy the error still occurred. I've just modified the WSP to deploy both DLLs to the GAC. I also removed the CAS policy from the Manifest.xml file. I'm hoping this resolves the issue. I will reply back after my tests.

Nov 18, 2009 at 6:44 PM

Modifying the Solution to deploy both DLLs to the GAC without the CAS policy seems to have fixed the issue. You may want to take a look at your CAS policy and verify that it provides the correct permissions for the DLL.

Thanks,

Thomas