Custom forms break functionality?

Aug 6, 2009 at 8:52 PM

I have been using this solution for a few weeks now and it has been working great.  I'm now seeing 2 problems after creating custom forms.

1.  After creating a new display form, I can no longer see any values for either the parent or child fields.

2.  When using either a custom edit or new form, the values I select (either field) are not saved when I hit OK.

 

I'm going to investigate further tomorrow as to exactly when the functionality breaks.  I want to say it seemingly works at first but I'm not sure I was paying close enough attention.  I figured I would post up here to see if anyone had similar issues.

Aug 7, 2009 at 2:36 PM

I figured out today that neither the newform or editform work when you customize them.  It's like they don't pass the values selected to the list or something.  Here's my method for creating a custom form:

1. New aspx page

2. Insert Custom List Form (New/Edit/Disp)

3. Attach masterpage

4. Save under the list's folder.

 

When viewing either the New or Edit form in SharePoint Designer, when it tries to render the fields it gives me this:

"An unhandled exception has occured. Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed."

I'm not sure if this is normal or if this is specific to the problem I'm having.

Coordinator
Aug 7, 2009 at 3:02 PM

Try the same steps after setting Trust to FULL in web.config.

Aug 7, 2009 at 3:17 PM

I changed my web.config to: <trust level="WSS_Full" originUrl="" />, did an IIS reset, created a new custom form, and the issue remained.

Just so I'm clear, I should be editing the web.config in 12\Config and not under Inetpub, correct?

Coordinator
Aug 7, 2009 at 3:50 PM

The inetpub is the right one

Aug 7, 2009 at 4:10 PM

Right now it's set to wss_custom, if I change it to wss_full, medium, or minimal I get a runtime error on the site.  The error is Unable to read the security policy file for trust level 'wss_full'.

Coordinator
Aug 7, 2009 at 4:45 PM

Mike! It is just "FULL", no WSS

Aug 7, 2009 at 5:15 PM

Sorry, havent had to do much web.config editing previously.  Made the change and now the control does render in SP Designer but it still does not save my selections back to the list with either a custom new or edit form.  I even created a new list and new forms just to be on the safe side.

 

Sep 28, 2009 at 3:38 PM

Hi All,

Please can you confirm that Customs forms DO NOT save, and that there is no known work around to this ? 

Just so that I can stop looking and move on to try something else if that is the case!!

Many thanks

Sep 28, 2009 at 4:28 PM

altozar, I never ended up having any luck resolving my issues.  I moved onto a different solution.

This one here also looks promising: http://spservices.codeplex.com/Wiki/View.aspx?title=%24%28%29.SPServices.SPCascadeDropdowns